re = /^([^.]+?\.)?text\.com$/m
str = 'text.com
test.text.com
foo.test.text.com
foo2.no.match.here.text.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end