import Foundation
let pattern = #"(?:\{\"Атрибуты\"\:\")([^"]+)(?:\"\},\{\"Атрибуты\"\:\")([^"]+)\"\}(?:,|)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"Атрибуты":"Разъем"},{"Атрибуты":"Lightning / Micro USB / Type-C"},
{"Атрибуты":"Тип разъема"},{"Атрибуты":"Универсальный"},
{"Атрибуты":"Сила тока, А"},{"Атрибуты":"3 А"},
{"Атрибуты":"Поддержка быстрой зарядки"},{"Атрибуты":"Да"},
{"Атрибуты":"Емкость батареи, мАч"},{"Атрибуты":"10000 мАч"},
{"Атрибуты":"Производитель"},{"Атрибуты":"EXPERTS"}]
На выходе в цикле
|$1---$2
Получится вот так:
Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д
Но нужно больше вводных данных.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)