Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?ms)\b\w*\b(?=\-\>.*)
"
s
Input 1
1
New
This is [INFO] 29 Jun- 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000| my first sentence SYSLOG- dds This is my [second] sentence.(?<=\[).*?(?=\].*) (?ms)(?<=\s)\w*(?=\-\>.*)