package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BE(.*)`)
var str = `BE65J6KN47
BE567800462
B-E6548764543
FR45646864
BF5538765
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}