$re = '/\d{1,2}\.\d{1,2}\.\d{2,4} \d{2}:\d{2}(:\d{2}){0,1}/';
$str = '07.01.2015 02:40';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);