#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\s\S]*)\b(\d+\.\d+\.\d+)\b([\s\S]*)"
Local $sString = "Microsoft (R) Windows Script Host Version 5.8" & @CRLF & _
"Copyright (C) Microsoft Corporation. All rights reserved." & @CRLF & _
"" & @CRLF & _
"58.0.3029 Copyright 2011 Google Inc."
Local $sSubst = "$1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)