re = /^[^\.\s][\w\-\.{2,}]+@([\w-]+\.)+[\w-]{2,}$/m
str = 'e..mail@mail.com
.email@mail.com
..email@mail.com
email.@mail.com
email..@mail.com
e@mail@mail.com
@email@mail.com
email@mail.com@
#email@mail.com
~email@mail.com
!email@mail.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end