$re = '/\b-\n\b/m';
$str = 'halfword-
secondhalfword
----
word
-
_________________';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;