package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z])-\n([a-zA-Z])`)
var str = `halfword-
secondhalfword
----
word
-
_________________`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}