use strict;
my $str = 'halfword-
secondhalfword
----
word
-
_________________';
my $regex = qr/([a-zA-Z])-\n([a-zA-Z])/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";