package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((a+)+)+)+$`)
var str = `aaaaaaaaaaaaaaaaaaaax`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}