use strict;
my $str = '<p><strong style="background:red">hola mundo</strong> este es el <hrsss/> dia de <img src="" /> <em>italica</em>.<p>';
my $regex = qr/(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\/\1>|<(hr|img)[^>]*?\/>)/p;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";