re = /(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\/\1>|<(hr|img)[^>]*?\/>)/
str = '<p><strong style="background:red">hola mundo</strong> este es el <hrsss/> dia de <img src="" /> <em>italica</em>.<p>'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result