package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+ +)(AB|DE|RG|DU)`)
var str = `23 AB 5400 DE 68 RG
33 DU 88 DE 8723 AB
55 RG 76 AB 92 DE`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}