# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+ +)(AB|DE|RG|DU)"
test_str = ("23 AB 5400 DE 68 RG\n"
"33 DU 88 DE 8723 AB\n"
"55 RG 76 AB 92 DE")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.