use strict;
my $str = 'S17,E108,736
S17,E109,737
';
my $regex = qr/^([^,]+),/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";