#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)6\/([1-9]|1[0-9]|2[0-9]|30)\/[0-9]{2}$|^[7-8]\/([1-9]|1[0-9]|2[0-9]|3[0-1])\/[0-9]{2}"
Local $sString = "col5date" & @CRLF & _
"7/4/22" & @CRLF & _
"8/29/22" & @CRLF & _
"10/9/22" & @CRLF & _
"12/12/20" & @CRLF & _
"9/1/19" & @CRLF & _
"9/1/22" & @CRLF & _
"9/22/19" & @CRLF & _
"2/16/22" & @CRLF & _
"6/16/22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")