import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "6\\/([1-9]|1[0-9]|2[0-9]|30)\\/[0-9]{2}$|^[7-8]\\/([1-9]|1[0-9]|2[0-9]|3[0-1])\\/[0-9]{2}";
final String string = "col5date\n"
+ "7/4/22\n"
+ "8/29/22\n"
+ "10/9/22\n"
+ "12/12/20\n"
+ "9/1/19\n"
+ "9/1/22\n"
+ "9/22/19\n"
+ "2/16/22\n"
+ "6/16/22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}