using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\.)\bmyTable\b";
string substitution = @"myTable3";
string input = @"val changeMe= ""select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x"" ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}