package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\n([^\|]*?(?:\|[^\|]*?)+?)`)
var str = `dsfdqsf
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqds|dsfqds|qfsd|qdfvqs
dfq
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqdqs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}