// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\n([^\|]*?(?:\|[^\|]*?)+?)").unwrap();
let string = "dsfdqsf
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqds|dsfqds|qfsd|qdfvqs
dfq
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqdqs";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}