package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).*\bChia\b.*`)
var str = `Chia seeds
i like to eat Chia seeds
i like to eat chia seeds
NoChia
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}