// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:1?\d{1,2}|2[0-4]\d|25[0-5])\.){3}(1?\d{1,2}|2[0-4]\d|25[0-5])\/(?:[0-9]|[1-2][0-9]|3[0-2])$").unwrap();
let string = "192.168.50.1/16
192.168.50.1/9
92.168.50.1/0
192.168.50.1/
0.0.0.0/0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}