# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<status>(IN|OUT)):\s+\"(?<license>[^\"]*)\"\s+(?<username>[^@]*)@(?<machine>.*)"
test_str = ("15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (licenses are reserved for others. (-101,396:10054 \"\"))\n"
"15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 \"\"))\n"
"15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 \"\"))\n"
"15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 \"\"))\n"
"15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 \"\"))\n"
"15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 \"\"))\n"
"15:21:54 (app1) OUT: \"lic_1\" user1@WKS1xxxx\n"
"15:21:54 (app1) UNSUPPORTED: \"lic_2\" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 \"\"))\n"
"15:21:54 (app1) UNSUPPORTED: \"lic_3\" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 \"\"))\n"
"15:21:54 (app1) UNSUPPORTED: \"lic_2\" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 \"\"))\n"
"15:21:54 (app1) IN: \"lic_3\" user2@WKS2xxxx\n"
"15:22:04 (app1) IN: \"lic_1\" user1@WKS1xxxx\n"
"15:22:20 (app1) OUT: \"lic_3\" user3@WKS22xxx")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.