import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?(\\d?)[-\\(\\.]?(\\d{3})[-\\)\\.\\s]?(\\d{3})[-\\.\\s]?\\d{4}";
final String string = "+1(845)664-2199\n"
+ "18456642199\n"
+ "8456642199\n"
+ "845.664.2199\n"
+ "1.845.664.2199\n"
+ "+18456642199\n"
+ "1(845)664-2199\n"
+ "(845)664-2199\n"
+ "845 664 2199\n"
+ "845-664-2199\n"
+ "1-845-664-2199\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}