re = /\+?(\d?)[-\(\.]?(\d{3})[-\)\.\s]?(\d{3})[-\.\s]?\d{4}/m
str = '+1(845)664-2199
18456642199
8456642199
845.664.2199
1.845.664.2199
+18456642199
1(845)664-2199
(845)664-2199
845 664 2199
845-664-2199
1-845-664-2199
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end