import Foundation
let pattern = #"\b(?:(port)|(dpi)|(fb_height)|(fb_width))="\K\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
bst.instance.red.port="5555"
bst.instance.red.dpi="240"
bst.instance.red.fb_height="900"
bst.instance.red.fb_width="1600"
bst.instance.red.first_boot="0"
bst.instance.redb.port="2000"
bst.instance.redb.dpi="120"
bst.instance.redb.fb_height="300"
bst.instance.redb.fb_width="800"
bst.instance.redb.first_boot="0"
bst.instance.redc.port="2000"
bst.instance.redc.dpi="120"
bst.instance.redc.fb_height="300"
bst.instance.redc.fb_width="800"
bst.instance.redc.first_boot="0"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1:+111}${2:+222}${3:+333}${4:+444}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)