using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<STYLE>).*(<\/STYLE>)";
string input = @" <STYLE>
group 1
</STYLE>
Random text here which shall not be removed.
<STYLE>
group 2
</STYLE>
Some more random text here which shall not be removed.
<STYLE>
group 3
</STYLE>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}