import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<STYLE>).*(<\\/STYLE>)";
final String string = " <STYLE>\n"
+ " group 1\n"
+ " </STYLE>\n"
+ " Random text here which shall not be removed.\n"
+ " <STYLE>\n"
+ " group 2\n"
+ " </STYLE>\n"
+ " Some more random text here which shall not be removed.\n"
+ " <STYLE>\n"
+ " group 3\n"
+ " </STYLE>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}