package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d{3}|\(\d{3}\))?)(\s|-|\.?)\d{3}(\s|-|\.)\d{4}(\s*(ext|x|ext.)\s*(\d{2,5})?)`)
var str = `123-231-3333 ext 12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}