$re = '/((\d{3}|\(\d{3}\))?)(\s|-|\.?)\d{3}(\s|-|\.)\d{4}(\s*(ext|x|ext.)\s*(\d{2,5})?)/';
$str = '123-231-3333 ext 12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);