re = /((\d{3}|\(\d{3}\))?)(\s|-|\.?)\d{3}(\s|-|\.)\d{4}(\s*(ext|x|ext.)\s*(\d{2,5})?)/
str = '123-231-3333 ext 12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end