// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\d{3}|\(\d{3}\))?)(\s|-|\.?)\d{3}(\s|-|\.)\d{4}(\s*(ext|x|ext.)\s*(\d{2,5})?)").unwrap();
let string = "123-231-3333 ext 12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}