import Foundation
let pattern = #"((\d{3}|\(\d{3}\))?)(\s|-|\.?)\d{3}(\s|-|\.)\d{4}(\s*(ext|x|ext.)\s*(\d{2,5})?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123-231-3333 ext 12345"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)