$re = '/^[A-Za-z0-9]+([-:._][A-Za-z0-9]+)*$/m';
$str = 'a
a.
.a
a.a
a..a
aa
aa.a
a.aa
aa..aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);