$re = '/(?:\d.*){9,}/m';
$str = '123454576889
12fsdfsdf34343434dfgfg34545
12345678aaaaaaaaaa
12345aaaa6789
(123)567-89-10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);