$re = '/\/tmp\/test-raj\/([^\/]+)\/.+/m';
$str = '/tmp/test-raj/abc/bcd.log
/tmp/test-raj/xyz/cccc.log
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);