re = /\/tmp\/test-raj\/([^\/]+)\/.+/m
str = '/tmp/test-raj/abc/bcd.log
/tmp/test-raj/xyz/cccc.log
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end