#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ax)(?:[^-A-Z0-9\.\/\\£]|\A)" & @CRLF & _
"[\.#]?" & @CRLF & _
"(" & @CRLF & _
"(?!\d{2}[-\\/]\d{2}[-\\/]\d{2,4})" & @CRLF & _
"(?=[A-Z\.\/\\]*?\d)" & @CRLF & _
"[-A-Z0-9\.\/\\]{3,10}[A-Z0-9]s?" & @CRLF & _
")" & @CRLF & _
"(?:[^-A-Z0-9\/\\]|\Z)"
Local $sString = "1 x 100 Sterostrip Washproof dressings or nearest items. Code DR/546"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")