package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^-A-Z0-9\.\/\\£]|\A)
[\.#]?
(
(?!\d{2}[-\\/]\d{2}[-\\/]\d{2,4})
(?=[A-Z\.\/\\]*?\d)
[-A-Z0-9\.\/\\]{3,10}[A-Z0-9]s?
)
(?:[^-A-Z0-9\/\\]|\Z)`)
var str = `1 x 100 Sterostrip Washproof dressings or nearest items. Code DR/546`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}