// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?:[^-A-Z0-9\.\/\\£]|\A)
[\.#]?
(
(?!\d{2}[-\\/]\d{2}[-\\/]\d{2,4})
(?=[A-Z\.\/\\]*?\d)
[-A-Z0-9\.\/\\]{3,10}[A-Z0-9]s?
)
(?:[^-A-Z0-9\/\\]|\Z)").unwrap();
let string = "1 x 100 Sterostrip Washproof dressings or nearest items. Code DR/546";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}