package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`departments":\["(.+?)"`)
var str = `1.)"departments":["Processed & Soft Cheese1"],`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}