use strict;
my $str = 'at (https://s.pinimg.com/mobile/js/pjs-CloseupPage-6b8daa054b87fb85384c.js:1:108083';
my $regex = qr/^\s*at\s(?<symbol>[^\r\n\t\f\v (]*?)?(?:\s*)?\(?(?<url>https?:\S+)\:(?<line>\d+):(?<column>\d+)\)?/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}