package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(Priority:\s[34]).*`)
var str = `Incident Assigned: ID: [IR244691] Priority: 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}