using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?m)^\={4}[\r\n]([\s\S]+?(?=^\={4}[\r\n]))^\={4}[\r\n]";
        string input = @"fdfdsfds
====
fdff
=====
nested
=====
fdfsf
====
=====
sfdfds
=====
====
dfdfsd
====
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}