package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b_*([a-z])[a-z]*(?:'s)?_*\b[^\n\w]*`)
var str = `Halley's Comet
First In, First Out
The Road _Not_ Taken
O'Brian's Dog`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}