#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\/api\/.*"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"https://example.com/api/does/match/" & @CRLF & _
"" & @CRLF & _
"https://example.com/should/not/match/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")