import re
regex = re.compile(r"(?P<email_address>[\w\.-]+@[\w\.-]+\.[\w]+)", flags=re.MULTILINE)
test_str = ("Name: Test Smith\n"
"Email: test@test.com\n"
"Phone: 123-456-7890\n"
"City: Dallas\n"
"State: TX\n"
"Zip: 75201\n"
"here is other text 2test@test.io\n"
"and some other stuff 94949494@stuff.co.in\n\n"
"If I write a paragragh with mutliple 99999@test.io and If I write a paragragh with mutliple 89999@test.mx.com and If I write a paragragh with mutliple 79999@test.com and If I write a paragragh with mutliple 69999@test.com and If I write a paragragh with mutliple 59999@test.com and \n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")