import Foundation
let pattern = #"(?<=<td.*?>)([0-3]?[0-9])\/([0-3]?[0-9])\/((?:[0-9]{2})?[0-9]{2})(?=.*?<\/td>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<table>
<tr>
<td class="test">9/2/2021 10:59:15 AM</td>
</tr>
<tr>
<td class="test">12/15/2015 12:10:45 PM</td>
</tr>
<tr>
<td class="test">10/10/2012 5:00:10 AM</td>
</tr>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2.$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)