// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+)\s+(\w+)(\(\d*\))?.*$").unwrap();
let string = "userId bigint(20) NO PRI auto_increment
createDate datetime YES
modifiedDate datetime YES
password_ varchar(75) YES
passwordEncrypted tinyint(4) YES
passwordModifiedDate datetime YES
sAMAccountName varchar(255) YES MUL
screenName varchar(75) YES UNI
screenNameModifiedDate datetime YES
emailAddress varchar(75) YES MUL
firstName varchar(75) YES
lastName varchar() YES
lastLoginDate datetime YES
active_ tinyint(4) YES MUL
phone varchar(25) YES
token varchar(75) YES
tokenValidUntil datetime YES
deletedAt datetime YES
deletedByUserId bigint(20) YES
eightByEightId varchar(100) YES
fitPushToken varchar(255) YES
-- query 2:
WORKORDER_NO varchar(32) NO PRI
WORKORDER_RES_ID varchar(18) NO PRI
ATTR_ID varchar(60) NO PRI
ATTR_NAME varchar(40) NO
ATTR_DISP_NAME varchar(256) YES
ATTR_VAL varchar(4000) YES
CONTROL_TYPE char(1) YES
DATA_SOURCE text YES
CONTROL_FLAG char(1) YES
ATTR_FLAG char(1) NO
DATA_TYPE char(1) YES
DATA_LEN int(4) YES
PRECISION int(2) YES
SCALE int(2) YES
IS_NULL char(1) YES
INIT_VALUE varchar(80) YES
STATE char(1) NO A
CREATE_USER decimal(9,0) YES
CREATE_DATE datetime YES
MODIFY_USER decimal(9,0) YES
MODIFY_DATE datetime YES ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}